Commit 3fd1942b authored by Stefan Funk's avatar Stefan Funk
Browse files

Merge branch 'develop' into 'main'

Develop

See merge request !14
parents e776dbb7 e204c135
......@@ -175,14 +175,14 @@ deploy_dev:
build_number: $PIPELINE_ID
full_version: '${VERSION}-BETA-${build_number}'
DEB_NAME: 'dariahde-geobrowser-beta_${full_version}.deb'
DEPLOY_DEB_COMMAND: 'curl -u ci:${APTLY_PASSWORD} -X PUT -H "Content-Type: application/json" --data "{}" ${APTLY_URL}/publish/:./indy'
DEPLOY_DEB_COMMAND: 'curl -u ${APTLY_USER}:${APTLY_PASSWORD} -X PUT -H "Content-Type: application/json" --data "{}" ${APTLY_URL}/publish/:./indy'
script:
- 'apk add --no-cache bash'
- 'apk add --no-cache curl'
- curl --version
- export DEB_FILE="$(ls ./*.deb)"
- curl -u ci:${APTLY_PASSWORD} -X POST --header "Content-Type:multipart/form-data" -F file=@${DEB_FILE} ${APTLY_URL}/files/${DEB_NAME}
- curl -u ci:${APTLY_PASSWORD} -X POST ${APTLY_URL}/repos/indy-releases/file/${DEB_NAME}
- curl -u ${APTLY_USER}:${APTLY_PASSWORD} -X POST --header "Content-Type:multipart/form-data" -F file=@${DEB_FILE} ${APTLY_URL}/files/${DEB_NAME}
- curl -u ${APTLY_USER}:${APTLY_PASSWORD} -X POST ${APTLY_URL}/repos/indy-releases/file/${DEB_NAME}
- echo $DEPLOY_DEB_COMMAND
- response=$(eval "$DEPLOY_DEB_COMMAND")
- echo $response
......@@ -199,14 +199,14 @@ deploy_live:
build_number: $PIPELINE_ID
full_version: '${VERSION}-${build_number}'
DEB_NAME: 'dariahde-geobrowser_${full_version}.deb'
DEPLOY_DEB_COMMAND: 'curl -u ci:${APTLY_PASSWORD} -X PUT -H "Content-Type: application/json" --data "{}" ${APTLY_URL}/publish/:./indy'
DEPLOY_DEB_COMMAND: 'curl -u ${APTLY_USER}:${APTLY_PASSWORD} -X PUT -H "Content-Type: application/json" --data "{}" ${APTLY_URL}/publish/:./indy'
script:
- 'apk add --no-cache bash'
- 'apk add --no-cache curl'
- curl --version
- export DEB_FILE="$(ls ./*.deb)"
- curl -u ci:${APTLY_PASSWORD} -X POST --header "Content-Type:multipart/form-data" -F file=@${DEB_FILE} ${APTLY_URL}/files/${DEB_NAME}
- curl -u ci:${APTLY_PASSWORD} -X POST ${APTLY_URL}/repos/indy-releases/file/${DEB_NAME}
- curl -u ${APTLY_USER}:${APTLY_PASSWORD} -X POST --header "Content-Type:multipart/form-data" -F file=@${DEB_FILE} ${APTLY_URL}/files/${DEB_NAME}
- curl -u${APTLY_USER}:${APTLY_PASSWORD} -X POST ${APTLY_URL}/repos/indy-releases/file/${DEB_NAME}
- echo $DEPLOY_DEB_COMMAND
- response=$(eval "$DEPLOY_DEB_COMMAND")
- echo $response
......
Bugfix Version 4.0.6
====================
* Change _window.hostname_ to _window.host_ to include the correct port automatically
Bugfix Version 4.0.5
====================
* Add main deploy stage
* Update documentation
Bugfix Version 4.0.4
====================
* Fix embed version
Bugfix Version 4.0.3
====================
......
......@@ -275,7 +275,7 @@ The current version of the DARIAH-DE Datasheet Editor is always accessible at ht
GIT Repository
--------------
* https://gitlab.gwdg.de/dariah-de/geo-browser/-/tree/master/edit
* https://gitlab.gwdg.de/dariah-de/geo-browser/-/tree/main
Bug Tracking
......
......@@ -209,7 +209,7 @@ Versions and Releases
You can find the current version of the Geo-Browser here: https://geobrowser.de.dariah.eu.
The CHANGELOG is available in the `GIT repository of the Geo-Browser <https://projects.gwdg.de/projects/geo-browser/repository>`_.
The CHANGELOG is available in the `GIT repository of the Geo-Browser <https://gitlab.gwdg.de/dariah-de/geo-browser/-/blob/main/CHANGELOG.md>`_.
Specification for Use
......@@ -244,7 +244,7 @@ GIT Repository
--------------
DARIAH-DE Geo-Browser Repository
* https://gitlab.gwdg.de/dariah-de/geo-browser/-/tree/master
* https://gitlab.gwdg.de/dariah-de/geo-browser/-/tree/main
GeoTemCo
* https://github.com/stjaenicke/GeoTemCo
......
......@@ -26,7 +26,7 @@ export function getDSID(){
return dsid;
}
export const host = window.location.protocol + '//' + window.location.hostname + ':' + window.location.port;
export const host = window.location.protocol + '//' + window.location.host;
// Some prefixes.
export const logIDPrefix = 'DATASHEET_';
......
{
"name": "dariahde-datasheet-editor",
"version": "4.0.5",
"version": "4.0.6",
"lockfileVersion": 2,
"requires": true,
"packages": {
"": {
"name": "dariahde-datasheet-editor",
"version": "4.0.5",
"version": "4.0.6",
"dependencies": {
"clipboard": "^2.0.8",
"handsontable": "^9.0.2",
......
{
"name": "dariahde-datasheet-editor",
"version": "4.0.5",
"version": "4.0.6",
"private": true,
"scripts": {
"build:beta": "webpack --config webpack.config.dev.js",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment