Verified Commit d1766d06 authored by hynek's avatar hynek 🤤
Browse files

build: revert most of the npm updates; update node-base instead

the npm version provided with node:12/14-buster-slim seems to be buggy => update npm to 8.1.2
parent b3e061af
FROM node:12-buster-slim as node-base
FROM node:14-buster-slim as node-base
RUN set -eux; \
apt-get update; \
......@@ -8,7 +8,11 @@ RUN set -eux; \
# node-gyp rebuild needs python and g++
python g++\
# fx's fixed intercooler installed from github
git
git \
ssh \
ca-certificates
RUN npm install -g npm@8.1.2
WORKDIR /app
COPY ./package.json /app
......@@ -16,7 +20,6 @@ COPY ./package-lock.json /app
RUN npm ci
ENV PATH ./node_modules/.bin/:$PATH
FROM node-base as client-builder
COPY . /app
RUN npm run build
......
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment