Commit 54be4640 authored by parciak's avatar parciak
Browse files

Added requirements. Removed old alembic and sqlalchemy requirements.


Signed-off-by: parciak's avatarMarcel Parciak <marcel.parciak@gmail.com>
parent eb16e864
Pipeline #163052 failed with stage
in 36 seconds
......@@ -15,8 +15,6 @@ pipenv-to-requirements = "*"
[packages]
cloudant = "*"
sqlalchemy = "*"
alembic = "*"
pytest = "*"
pycdstar3 = {git = "https://gitlab.gwdg.de/cdstar/pycdstar3"}
jinja2 = "*"
......
......@@ -15,18 +15,25 @@
################################################################################
appdirs==1.4.4
attrs==19.3.0
black==19.10b0
click==7.1.2
fastapi==0.60.1
h11==0.9.0
httptools==0.1.1 ; sys_platform != 'win32' and sys_platform != 'cygwin' and platform_python_implementation != 'PyPy'
pathspec==0.8.0
pydantic==1.6.1
regex==2020.7.14
starlette==0.13.6
toml==0.10.1
black==20.8b1
certifi==2020.12.5
click==7.1.2 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3, 3.4'
distlib==0.3.1
fastapi==0.62.0
filelock==3.0.12
h11==0.11.0
mypy-extensions==0.4.3
pathspec==0.8.1
pbr==5.5.1 ; python_version >= '2.6'
pipenv-to-requirements==0.9.0
pipenv==2020.11.15 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
pydantic==1.7.3 ; python_version >= '3.6'
regex==2020.11.13
six==1.15.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
starlette==0.13.6 ; python_version >= '3.6'
toml==0.10.2 ; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'
typed-ast==1.4.1
uvicorn==0.11.6
uvloop==0.14.0 ; sys_platform != 'win32' and sys_platform != 'cygwin' and platform_python_implementation != 'PyPy'
websockets==8.1
typing-extensions==3.7.4.3
uvicorn==0.12.3
virtualenv-clone==0.5.4 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
virtualenv==20.2.2 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
......@@ -2,52 +2,43 @@
#
# SPDX-License-Identifier: GPL-3.0-or-later
alembic==1.4.2
appdirs==1.4.4
attrs==19.3.0
black==19.10b0
certifi==2020.6.20
################################################################################
# This requirements file has been automatically generated from `Pipfile` with
# `pipenv-to-requirements`
#
#
# This has been done to maintain backward compatibility with tools and services
# that do not support `Pipfile` yet.
#
# Do NOT edit it directly, use `pipenv install [-d]` to modify `Pipfile` and
# `Pipfile.lock` and then regenerate `requirements*.txt`.
################################################################################
alembic==1.4.3
attrs==20.3.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
certifi==2020.12.5
chardet==3.0.4
click==7.1.2
cloudant==2.13.0
distlib==0.3.1
fastapi==0.59.0
filelock==3.0.12
h11==0.9.0
httptools==0.1.1
idna==2.10
iniconfig==1.0.0
iso8601==0.1.12
Jinja2==3.0.0a1
Mako==1.1.3
MarkupSafe==2.0.0a1
more-itertools==8.4.0
packaging==20.4
pathspec==0.8.0
pbr==5.4.5
pipenv==2020.6.2
pipenv-to-requirements==0.9.0
pluggy==0.13.1
py==1.9.0
cloudant==2.14.0
idna==2.10 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
iniconfig==1.1.1
iso8601==0.1.13
jinja2==2.11.2
mako==1.1.3 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
markupsafe==1.1.1 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
packaging==20.7 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
pluggy==0.13.1 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
py==1.9.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
pycdstar3 @ git+https://gitlab.gwdg.de/cdstar/pycdstar3@bde5c7ee604a74e8b20d770716a59310b8f19166#egg=pycdstar3
pydantic==1.6
pyparsing==3.0.0a2
pytest==6.0.0rc1
python-dateutil==2.8.1
pyparsing==2.4.7 ; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'
pytest==6.1.2
python-dateutil==2.8.1 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
python-editor==1.0.4
regex==2020.6.8
requests==2.24.0
python-liquid==0.5.6
requests-toolbelt==0.9.1
six==1.15.0
SQLAlchemy==1.3.18
starlette==0.13.4
requests==2.25.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3, 3.4'
six==1.15.0 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
sqlalchemy==1.3.20
tabulate==0.8.7
toml==0.10.1
tqdm==4.48.0
typed-ast==1.4.1
urllib3==1.25.10
uvicorn==0.11.5
uvloop==0.14.0
virtualenv==20.0.28
virtualenv-clone==0.5.4
websockets==8.1
toml==0.10.2 ; python_version >= '2.6' and python_version not in '3.0, 3.1, 3.2, 3.3'
tqdm==4.54.1 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3'
urllib3==1.26.2 ; python_version >= '2.7' and python_version not in '3.0, 3.1, 3.2, 3.3, 3.4' and python_version < '4'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment