package.json 1.21 KB
Newer Older
Mathias Goebel's avatar
Mathias Goebel committed
1
2
3
4
{
  "name": "viewer",
  "version": "0.0.1",
  "description": "Viewer for the modular framework to present digital editions",
5
  "productName": "EMo Viewer",
Mathias Goebel's avatar
Mathias Goebel committed
6
7
  "cordovaId": "de.uni-goettingen.sub.emo",
  "capacitorId": "",
8
9
10
11
  "author": [
    "Mathias Göbel <goebel@sub.uni-goettingen.de>",
    "Frank Schneider <frank.schneider@sub.uni-goettingen.de>"
  ],
schneider210's avatar
schneider210 committed
12
13
14
  "contributors": [
    "Nils Windisch"
  ],
Mathias Goebel's avatar
Mathias Goebel committed
15
16
  "private": true,
  "scripts": {
17
    "build": "quasar build",
18
    "dev": "quasar dev --modern",
19
    "lint": "eslint --ext .js,.vue src"
Mathias Goebel's avatar
Mathias Goebel committed
20
21
  },
  "dependencies": {
22
    "@quasar/extras": "^1.7.0",
23
    "openseadragon": "^2.4.2",
schneider210's avatar
schneider210 committed
24
    "quasar": "^1.12.4"
Mathias Goebel's avatar
Mathias Goebel committed
25
26
  },
  "devDependencies": {
schneider210's avatar
schneider210 committed
27
    "@quasar/app": "^1.9.6",
28
    "autoprefixer": "^9.7.6",
Mathias Goebel's avatar
Mathias Goebel committed
29
30
    "babel-eslint": "^10.0.1",
    "eslint": "^6.8.0",
schneider210's avatar
schneider210 committed
31
    "eslint-config-airbnb-base": "^14.2.0",
Mathias Goebel's avatar
Mathias Goebel committed
32
    "eslint-loader": "^3.0.3",
schneider210's avatar
schneider210 committed
33
    "eslint-plugin-import": "^2.21.2",
34
    "eslint-plugin-vue": "^6.1.2",
schneider210's avatar
schneider210 committed
35
36
    "node-sass": "^4.14.1",
    "sass": "^1.26.8",
37
    "sass-loader": "^8.0.2"
Mathias Goebel's avatar
Mathias Goebel committed
38
39
40
41
42
43
44
45
46
47
48
49
50
  },
  "engines": {
    "node": ">= 10.18.1",
    "npm": ">= 6.13.4",
    "yarn": ">= 1.21.1"
  },
  "browserslist": [
    "last 1 version, not dead, ie >= 11"
  ],
  "resolutions": {
    "@babel/parser": "7.7.5"
  }
}